1. Welcome to Photography Forum. Our photography community!

    Photography-forum is dedicated to those who have passion, desire and love of photography and want to improve their photographic technique. It doesn't matter what you photograph, landscapes, weddings, portraits or your photographic experience, it's about learning and loving what we do. Photography!

    If you want learn and expand your photography skills then there is one place to do it Photography Forum !!!

    You are viewing photography-forum as a guest which gives you limited access to view most forums and enjoy other features. By joining our free community you will be able to post photographs for critique, join in the monthly photography competitions, respond to polls, upload content and enjoy many other special features. Registration is fast, simple and absolutely free so please join Photography Forum.

    If you have any problems please contact us.

    The Photography-Forum Team
    Dismiss Notice
  2. PLEASE SEE RULES BEFORE POSTING LINKS
    Click here to see Forum Rules

Thank god they updated lightroom again and fixed the bugs.

Discussion in 'Photoshop & Editing Chat Forum' started by Kevin Fox, Sep 24, 2016.

  1. Kevin Fox

    Kevin Fox Always on Premium Member

    Messages:
    4,848
    Edit my images ?:
    Yes (recommended)
    It's so dam slow now, it's unusable. Adobe get your **** together!
     
  2. paulmag

    paulmag Always on Honorary Life Member

    Messages:
    57,271
    Edit my images ?:
    Yes (recommended)
    Oops I had to revert back to lr5 from lr6 as it wouldn't work for me on my pc .....
    .
    Edit
    Should say this was when 6 was first released I did get a refund for the failed upgrade from adobe
     
    Last edited: Sep 25, 2016
    Kevin Fox likes this.
  3. steve b

    steve b Always on Premium Member

    Messages:
    11,958
    Edit my images ?:
    Yes (recommended)
    I think my Elements 13 has been updated, it's not as it was, which is bloody annoying for a creature of habit like me.
     
    Kevin Fox likes this.
  4. tenchy

    tenchy Rain maker Administrator

    Messages:
    202,131
    Edit my images ?:
    Yes (recommended)
    my SOP for eveything:
    install, ensuring no net access. open, find anything and everything to do with updates, turn off.

    See if it works OK.

    If yes, carry on using it ad infinitum, no need to post about it being broken in future.

    :whistle3:
     
    Kevin Fox likes this.
  5. hooferinsane

    hooferinsane EXIF Seeker Super Moderator

    Messages:
    10,087
    Edit my images ?:
    Yes (recommended)
    No problems with LR update here so far - try turning off use graphics processor
     
    Kevin Fox likes this.
  6. DonS

    DonS Stuck in Toronto Moderator

    Messages:
    9,675
    Edit my images ?:
    Yes (recommended)
    Must be Windows? Mine is no different than it was before the last update on my Mac. My graphics processor is not supported so I have never had that on.
     
  7. paulmag

    paulmag Always on Honorary Life Member

    Messages:
    57,271
    Edit my images ?:
    Yes (recommended)
    The problem with updates is ....................amongst other things the inability to check it runs on all hardware especially as there is so many builds for windows machines.............and I suspect the developers use of the newest kit and driving users to "upgrade" hardware when its just easier to make could that needs more muscle and memory.

    I had to give in when LR6 was launched even though my spec machine should have enough grunt and capacity to deal with LR
     
    Kevin Fox likes this.
  8. DonS

    DonS Stuck in Toronto Moderator

    Messages:
    9,675
    Edit my images ?:
    Yes (recommended)
    I found LR 5 slow and LR 6 faster. Of course this latest version can be even faster, you can set it to directly edit just the smart previews which saves all kinds of resources.

    You’ve always been able to use Smart Previews in the Develop Module as a way to edit photos without having access to the original images on disk. Astute customers reported faster performance in the Develop Module when using Smart Previews and keeping their original images disconnected from their computer. Now, you can set a Preference in the Performance tab so that Lightroom will always use Smart Previews in the Develop Module, if they are available, even when the original files are also available.

    To do so,

    1. Choose Edit > Preferences.
    2. In the Preferences dialog, select the Performance tab.
    3. In the Develop section, select Use Smart Previews Instead Of Originals For Image Editing.
    4. Click OK and then restart Lightroom.
     
    Kevin Fox and paulmag like this.
  9. yasser

    yasser Here a lot Premium Member

    Messages:
    425
    Edit my images ?:
    Yes (recommended)
    I've had problems with loading the Nik software to my LR5.7.1. Turning off use graphics processor is one of the fixes but I've never found it. If you know how, please could you tell me..
     
  10. paulmag

    paulmag Always on Honorary Life Member

    Messages:
    57,271
    Edit my images ?:
    Yes (recommended)
    just installed it so I can show you :) thanks

    Capture.jpg
     
    yasser likes this.
  11. yasser

    yasser Here a lot Premium Member

    Messages:
    425
    Edit my images ?:
    Yes (recommended)
    @paulmag, Thank you. I was looking for it in LR itself
     
  12. paulmag

    paulmag Always on Honorary Life Member

    Messages:
    57,271
    Edit my images ?:
    Yes (recommended)
    Lightroom 5.X doesnt use the GPU so there is no setting to turn it off it was something introduced in LR6
     

Share This Page